AT&T Application Resource Optimizer (ARO) - Nexus 6P issue with ARO

Nexus 6P issue with ARO
05.15.2017 01:54 AM
Dear Team , 

Kindly your support of have issue with Nexus 6p , not detecting the device with ARO latest devise , meantime when the ARO software opening it give two error meassges "FFMEGE is not installed and VLC installation need" despite both requirement already installed  .

BR
Aso 
Re: Nexus 6P issue with ARO
05.16.2017 11:43 AM
Hi Aso, 

Are you using a PC or a Mac?  I am guessing PC based on the VLC requirement?

In a terminal - does "adb devices" show your device?

Do you have the adb path properly noted in Video Optimizer? File -> Set ADB location? (in Windows add the ".exe" at the end)

Doug


Re: Nexus 6P issue with ARO
05.16.2017 10:30 PM
Hi Doug

Using PC windows7, and ADB is defined on terminal, for the last question may you give more detail it is not clear .

BR

Aso 
Re: Nexus 6P issue with ARO
05.17.2017 07:37 AM
Aso, 

1.  ARO is now called Video Optimizer. we just released a new version last week.  Check it out for some great new features:   developer.att.com/video-optimizer


2.  Inside Video Optimizer - File menu-> set ADB location. Is it properly set?  You must define ADB here for it to find your device.  Since you are running Windows, you must include "adb.exe" with the .exe at the end.  Once you have filled out this menu item, restart Video Optimizer, and your device will be discovered by the tool.

Doug
Re: Nexus 6P issue with ARO
05.18.2017 01:06 AM
Dear 

Still couldnot find the device with steps you mentioned.

BR
Aso 
Re: Nexus 6P issue with ARO
05.18.2017 10:34 AM
Sorry you are having issues.

To confirm - in a command window - when you type "adb devices" your device shows up as available?

AFter you set the ADB path inside Video Optimizer - did you restart the app?

Doug
Re: Nexus 6P issue with ARO
05.20.2017 10:51 PM
Hi Doug 

Run the command to see the connection according to below but give 

C:\>Users\aso.jumaa\AppData\Local\Andriod\andriod-sdk\platform-tool>adb device
Access is denied.

BR
Aso 
Re: Nexus 6P issue with ARO
05.21.2017 05:35 AM
Aso, 

On your device- make sure you have adb debugging turned on.

If you still get access is denied ( the command is adb devices), than you have entered a really unpleasant zone where Windows has installed the incorrect driver...or perhaps just not the adb driver.  Uninstall all the active phone drivers (when phone is plugged in) and let it try again.  There are some good threads on StackOverflow on this subject.

Before that, you could also try a different USB cable. I know, it sounds weird, but that sometimes does resolve weird connection issues.

Doug